Results 1 to 4 of 4

Thread: [SOLVED] Co-existing with another mta but stuck at the last hurdle

  1. #1
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default [SOLVED] Co-existing with another mta but stuck at the last hurdle

    Hi all

    I have got zimbra listening on port 81 so things happily co-exist with apache. I have set the mta to listen on port 26 so exim starts great. I've got exim to forward mails to port 26 and zimbra picks it up. The last bit has got me stumped. When I set the "Relay MTA for external delivery" to localhost:25 the mail goes into a queue with the error "mail loops back to myself". But that's what I want it to do, loop back to localhost but on port 25 so exim can pick it up and deal with it. I have to use exim, it is doing really useful stuff that isn't available with zimbra. My main customer is a big company and can have another mta so there isn't a problem but all my other customers can't justify two mail servers, they aren't big enough so I can't use zimbra with them unless I can get it running with exim on the same server. I'd be well happy if someone could help me out.

    Thanks

    Mike

  2. #2
    peter@mxtoolbox.com is offline Partner (VAR/HSP)
    Join Date
    Feb 2007
    Location
    Austin, TX
    Posts
    110
    Rep Power
    8

    Default

    I'd try assigning another IP to the box and binding exim to listen on port 25 on that IP. Then you can setup a real external MTA and Zimbra shouldn't realize that it's local.

    If you can't have two machines, have two addresses
    Peter LeBlond
    Product Development Engineer
    http://www.mxtoolbox.com


  3. #3
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default

    Thanks for the reply

    I did that but I get the same error only with the new IP address listed. postfix seems to listen on both address as I can telnet to both. if I look in main.cf there is a directive "mynetworks" that includes 10.0.0.0/24. not sure if this makes postfix listen on all address in the network but if I change it to 10.0.0.1/24 and then su zimbra - postfix reload it gets reset back to 10.0.0.0/24. In the postfix script there is a rewriteconfig call. I'm not a postfix guru and don't know how to force it to listen on one IP address and don't know how to stop the postfix reload changing things back.

  4. #4
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Stats don't update
    By Doug_M in forum Administrators
    Replies: 33
    Last Post: 05-05-2007, 08:17 PM
  3. Replies: 3
    Last Post: 05-04-2007, 03:22 PM
  4. MTA config is 'stuck'
    By sroylance in forum Administrators
    Replies: 5
    Last Post: 03-30-2007, 08:43 AM
  5. Server Stats Cont...
    By DMRDave in forum Administrators
    Replies: 15
    Last Post: 02-16-2006, 01:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •