Results 1 to 5 of 5

Thread: [SOLVED] Changed Backup Target Did Not Change For LDAP

  1. #1
    rfoster is offline Active Member
    Join Date
    Aug 2007
    Location
    U.S. Pacific Northwest
    Posts
    25
    Rep Power
    8

    Default [SOLVED] Changed Backup Target Did Not Change For LDAP

    Hi,

    I used the admin UI to change the backup target from /opt/zimbra/backup to /opt/zbackup. The sessions backups are now landing in the new target directory but ldap backups are still going to the original. I haven't seen any posts or bugs about this.

    Here's the target directory's ls -l output:

    Code:
    drwxrwsr-x  5 zimbra zimbra  4096 2007-10-25 08:40 zbackup
    I'm using 4.5.9 with Ubuntu 6.10

    I can post a bug if it is one. Meanwhile, I'll just deal with it by making /opt/zimbra/backup a symlink to my intended target.

    Thanks,

    Bob

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Bug 21753 - ldap backup not kept with rest of backup


    hm, wonder if this just cropped up in the time since we added the functionality to change the target in the admin console...4.5.5? (don't feel like throwing on 4.5.4 to test)
    or if zmbackup -t doesn't have an effect either, which could mean that it might also be left over from several ldap backup designs:
    Bug 14069 - backups in the admin console should back up LDAP data
    Bug 8365 - System LDAP is backuped only when -a all is specified
    Bug 9551 - LDAP backup directory format difference between full install and ldap only install
    Bug 7420 - Zmbackup ldap data is not backed up if target server is not hosting it.

    some snips/paraphrasing:
    desired: full from admin console should do same as zmbackup -f. incremental from admin console should do same as zmbackup -i.
    a backup is done per server. The backups on a mail- store-only box will include LDAP data for the accounts on that box. But in ZCS LDAP stores more than account data -- it has domain info, server config, etc. So you have to run a backup on the box that has a master LDAP server as well. In the event you have a server with a mail store and the master LDAP server, this additional LDAP data will automatically get dumped. On a node that has LDAP but no mailbox server, zmbackupldap is invoked or zmbackup -l when all accounts are done (either in a full or incremental), -l is assumed to be present. otherwise (-a <named-accounts>) no LDAP dump is done unless -l is specified - see also zmslapcat
    Last edited by mmorse; 11-13-2007 at 10:46 PM.

  3. #3
    rfoster is offline Active Member
    Join Date
    Aug 2007
    Location
    U.S. Pacific Northwest
    Posts
    25
    Rep Power
    8

    Default

    Looks like the bug got posted right after I searched for it! Thanks for the quick response.

    Bob

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    No problem, actually it was just a day before: backups to tape
    The last modified timestamp of just now comes from some internal notes/marking it as new etc, but thanks for seconding!
    Last edited by mmorse; 11-13-2007 at 04:43 PM.

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    -seeing as we have a very simple workaround and a bug listed in this thread I'm going to mark it as solved

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 210
    Last Post: 01-17-2012, 01:19 AM
  2. FYI: ZCS NE backup to fuse/sshfs mount, worked.
    By jagipson in forum Administrators
    Replies: 0
    Last Post: 09-28-2007, 06:37 AM
  3. 5.0 Install tasks
    By JoshuaPrismon in forum Installation
    Replies: 2
    Last Post: 06-06-2007, 12:18 PM
  4. httpd resident in memory but not accessible
    By AlexanderH in forum Installation
    Replies: 3
    Last Post: 05-11-2007, 09:19 AM
  5. Set default backup target for zmschedulebackup?
    By Kirkaiya in forum Administrators
    Replies: 2
    Last Post: 04-11-2006, 02:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •