Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Performance Issues

  1. #1
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default Performance Issues

    We seem to have intermittent connectivity issues client to server. Progress bars will just show connecting and just not do anything, sometimes it will eventually throw up and error that "the server can't be reached at this time".
    I can contact the server through ssh and remote desktop with no problem. Memory seems not to be an issue, nor processors; they seem to be at a reasonable state. The logs are either no help, or I am not looking for the right things.

    Can anyone give me some direction on where to look and what to look for?

    750 users
    Version 4.5.6_GA_1044.MACOSXx86 Jul 6, 2007
    OS X 10.4.10
    2 x 2 GHZ Dual Core Intel Xeon, 6 GB RAM

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Hey dketchum,
    -zimbra related logfiles: /docs/ne/latest/administration_guide/9_Monitoring.12.1.html#1075561
    feel free to attach your logs if you'd like (/opt/zimbra/log/mailbox.log & /var/log/zimbra.log being the biggies)
    -your system logfiles
    -you also might want to analyze some tcpdumps
    -as you're an NE customer you could also open a support request if you'd like someone to take a look
    (of course there's also 4.5.9 you can upgrade too, but that's an asside)
    Last edited by mmorse; 11-09-2007 at 03:18 PM.

  3. #3
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default

    mmorse,
    Thank you for your quick reply.
    If we don't see something from these logs, I will open a service request. I did not see mailbox.log in /opt/zimbra/, there is a mail.log? in /var/log/ is that the same? The logs are both well beyond the file size attachment suggestions, will that be a problem? The zimbra.log is 22 MB and the mail.log is 65 MB

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    meant to say /log and not /logs
    so it's /opt/zimbra/log/mailbox.log

    Certainly crop portions and attach them in a zip as needed.
    Of course you can host them somewhere on your own or another free location. (the yousendit's etc)
    There's also zimbra private pastebin - collaborative debugging tool if needed.

    -If you end up contacting support for it there will be ways of getting them the logs.
    But you can certainly ask us, aka: 'the free forum support' as well!
    Last edited by mmorse; 11-09-2007 at 01:35 PM.

  5. #5
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default

    Ah, I see where I went wrong with the log location.

    We did find a warn in the log. Is it relevant?

    mailbox.log.2007-11-08:2007-11-08 13:59:59,107 WARN [LmtpServer-16]
    [name=emailuser@ourdomain,org;] dbconn - Connection pool is 75%
    utilized. 12 connections out of a maximum of 12 in use. Turn on
    debug logging for zimbra.dbconn to see stack traces of connections not
    returned to the pool.

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    could you attach your output of:
    su zimbra
    postconf
    &
    zmlocalconfig
    &
    zmprov gs server.domain.com (zmprov gacf is a little less accurate if you've changed your settings in the individual server vs globally)
    Last edited by mmorse; 11-09-2007 at 07:51 PM.

  7. #7
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default

    Looks like it is going to have to be 3 posts as the output is too long. Thanks for your help.

    zmail:~ zimbra$ postconf
    Attached Files Attached Files
    Last edited by mmorse; 11-09-2007 at 07:54 PM. Reason: made into attachment

  8. #8
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default

    zmail:~ zimbra$ zmlocalconfig
    Attached Files Attached Files
    Last edited by mmorse; 11-09-2007 at 08:07 PM. Reason: also made into attachment

  9. #9
    dketchum is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Arizona
    Posts
    20
    Rep Power
    7

    Default

    zmail:~ zimbra$ zmprov gacf
    Attached Files Attached Files
    Last edited by mmorse; 11-09-2007 at 08:05 PM. Reason: made into attachment and removed license etc

  10. #10
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Quote Originally Posted by dketchum View Post
    mailbox.log.2007-11-08:2007-11-08 13:59:59,107 WARN [LmtpServer-16] [name=emailuser@ourdomain,org;]
    dbconn - Connection pool is 75% utilized.
    12 connections out of a maximum of 12 in use.
    Turn on debug logging for zimbra.dbconn to see stack traces of connections not returned to the pool.
    My best guess is that your database connections can't keep up with the load or something.
    12 out of 12 is not 75% -But I think it's just that the warning crops up at 75%

    So if you wanted to track it down-
    edit: /opt/zimbra/conf/log4j.properties
    and add: log4j.logger.zimbra.dbconn=DEBUG

    But why don't you make a good backup and upgrade to 4.5.9 because there have been a lot of performance improvements.

    As you on NE:
    -First use zmbackup (the backups your currently used to)
    -Though I know you can restore from the backups, if you can afford the extra few min of downtime it often helps to have the structure easily accessible:

    Obviously backup any other mounted locations that you use, the below is just assuming everything's stored in /opt/zimbra/
    su zimbra
    zmcontrol stop
    exit/switch back to root
    ps aux | grep zimbra (kill -9 pid on any remaining)
    mkdir /backup
    rsync -avHK /opt/zimbra/ /backup/zimbra

    When that finishes, if you want you can tar it up as well for 'easy' movement to another location:
    mkdir /backuptar
    tar -zcvf /backuptar/zimbra.456_1044.200711##.backup.gz -C /backup/zimbra .
    Last edited by mmorse; 11-09-2007 at 08:55 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Performance Issues
    By skyphyr in forum Administrators
    Replies: 4
    Last Post: 08-08-2007, 09:03 AM
  2. Exchange 2003 Migration Issues
    By JordanPWilliams in forum Migration
    Replies: 10
    Last Post: 07-27-2007, 10:51 AM
  3. Need Help Troubleshooting Web Client Issues
    By soxfan in forum Administrators
    Replies: 2
    Last Post: 03-23-2007, 05:27 AM
  4. Replies: 11
    Last Post: 12-03-2006, 01:29 PM
  5. Performance, spam and lot more
    By montievv in forum Administrators
    Replies: 1
    Last Post: 07-24-2006, 11:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •