Results 1 to 5 of 5

Thread: Server Rename Glitches

  1. #1
    leog21 is offline Special Member
    Join Date
    Sep 2007
    Posts
    123
    Rep Power
    7

    Default [Solved] Server Rename Glitches

    Hi,

    I successfully renamed my production server following your wiki instructions.

    However a few settings did not change despite the fact that the webadmin interface shows the new domain.

    zimbraNotebookAccount: wiki@olddomain.net

    zimbraSpamIsNotSpamAccount: ham.qvqx7faa@olddomain.net

    zimbraSpamIsSpamAccount: spam.ipyhgbzfj@olddomain.net


    I tried editing them manually:
    Code:
    zmprov ms. server.domain.com zimbraNotebookAccount wiki@newdomain.net
    but I get the following error:

    Code:
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraNotebookAccount' not allowed])
    Thanks for your help.
    Last edited by leog21; 11-08-2007 at 03:05 PM. Reason: resolved

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    So if you we're talking about ZmSetServerName - Zimbra :: Wiki that has nothing do to with your domains, it's the server hostname.

    There's also a new command for 5.0 zmprov renameDomain(rd) to take care of renaming all the accounts.

    Ok, what you would want is:
    zmprov ra spam.ipyhgbzfj@olddomain.net spam@newdomain.net
    zmprov mcf zimbraSpamIsSpamAccount spam@newdomain.net

  3. #3
    leog21 is offline Special Member
    Join Date
    Sep 2007
    Posts
    123
    Rep Power
    7

    Default

    Thanks for your reply. I'm using ZCS 4.5.7

    when I type that command I get:

    Code:
    ERROR: account.NO_SUCH_ACCOUNT (no such account: spam.ipyhgbzfj@olddomain.com)
    So which one is accurate? the output from zmprov gacf ? or the admin console which shows spam.ipyhgbzfj@newdomain.com

    Thanks,

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Oh so you did already rename the account then. (a quick list of all your accounts is just zmaccts)

    gacf is the config - it's not tied to the account itself

    run:
    zmprov mcf zimbraSpamIsSpamAccount spam.ipyhgbzfj@newdomain.com
    check by:
    zmprog gacf | grep zimbraSpamIsSpamAccount

  5. #5
    leog21 is offline Special Member
    Join Date
    Sep 2007
    Posts
    123
    Rep Power
    7

    Default

    that fixed it, thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •