Results 1 to 9 of 9

Thread: [SOLVED] Zimbra on OSX - returned mail, hostname problem?

  1. #1
    McBurtnieks is offline Member
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Thumbs up [SOLVED] Zimbra on OSX - returned mail, hostname problem?

    At first, thank you, Zimbra people, for good work and continous efforts... :-)
    Congrats for your business victory! Ummm...

    My OpenSource Zimbra installation (4.5.3 GA) works on client OSX Tiger (10.4.9) installation for 6 months.
    I have ~ 30 accounts, exchanging ~300 e-mails every day.
    Several accounts grow on size over 1 Gb now, but Zimbra and PPC G4 coping with it quite OK.
    (Machine - Mac G4 700 MHz, 1.25 Gb RAM, 120 Gb HD, directly connected to internet)

    There are no big issues with workflow, only few - sometimes logger stops working by itself, but server continues normally, and thats all... EXCEPT:

    Just SOME other MTAs is returning/not accepting mail from my Zimbra because on wrong/not qualified HOSTNAME.

    I have static IP and FQDN both for "mail.mydomain.com" and "webmail. mydomain.com".
    (Notice: I choose name "webmail" because I felt it good for my purpose and then registered that name "webmail.mydomain.com" with my TLD. In this way I got address "webmail.mydomain.com" pointing to my machine for user access to webmail interface).

    My HOSTS file:
    Code:
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1       localhost
    255.255.255.255 broadcasthost
    xx.xx.xxx.xxx webmail.mydomain.com webmail
    When I installed Zimbra, I found that ONLY way to get Zimbra installation working is to set OSX Computer Name to "webmail", NOT "mail.mydomain.com", webmail.mydomain.com" or just "mydomain.com". When I set Computer Name to other than "webmail", installation never succeeded. I don't remember exact reasons but there was issues about LDAP not finding localhost and something like.
    OSX, as always, automagically adds .local to Computer Name.
    So, I notice in logs that Postfix manifests to outside world as "webmail.local". And this is not good.
    And I see that it is problem here:

    --sample from returned mail--
    Code:
    <mma@mgn.ru>: host relay.mgn.ru[62.165.51.253] refused to talk to me: 501 5.7.1
        <webmail.local>: Helo command rejected: Host not found
    Reporting-MTA: dns; webmail.local
    X-Postfix-Queue-ID: C6FE76C4022
    X-Postfix-Sender: rfc822; user@mydomain.com
    Arrival-Date: Tue,  6 Nov 2007 10:46:07 +0200 (EET)
    
    Final-Recipient: rfc822; mma@mgn.ru
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; host relay.mgn.ru[62.165.51.253] refused to talk to
        me: 501 5.7.1 <webmail.local>: Helo command rejected: Host not found
    --end of sample--

    Is there any way to tell Zimbra Postfix to use FQDN when talking to other mailservers?

    As I see, only few MTAs checks this now, because my server succesfully exchanges mails with LOT of servers on internet without problems for almost half-year, but some mails fail...

    Thank you,
    McBurtnieks
    Last edited by McBurtnieks; 11-14-2007 at 06:58 PM. Reason: problem solved

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Your hosts file is incorrect, for the loopback it should read as follows:

    Code:
    127.0.0.1 localhost.localdomain localhost
    as detailed in the documentation.

    Check your configuration with the following:

    Code:
    host `hostname`  <-- type 'as-is' and with backticks not single quotes
    dig yourdonain.com any
    dig yourdomain.com mx
    Do you have a local DNS server installed? Are you on a LAN or public IP? Any firewall on the zimbra server or in frontr of it?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Mark Daniel's Avatar
    Mark Daniel is offline Senior Member
    Join Date
    May 2007
    Location
    Ferndale, MI
    Posts
    54
    Rep Power
    8

    Default

    You may also want to modify your /etc/hostconfig file, and change "HOSTNAME" from "-AUTOMATIC-" to your FQDN (mail.mydomain.com).
    Last edited by Mark Daniel; 11-08-2007 at 06:09 AM. Reason: clarification

  4. #4
    McBurtnieks is offline Member
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Default Re: Zimbra on OSX - returned mail, hostname problem

    Quote Originally Posted by phoenix View Post
    Your hosts file is incorrect, for the loopback it should read as follows:

    Code:
    127.0.0.1 localhost.localdomain localhost
    Are you on a LAN or public IP? Any firewall on the zimbra server or in front of it?
    Thank you for answer.
    1. You point me to changing HOST file first entry to above-mentioned. Do you recognise that this is on OS X? Or it is just the way you set hosts file on Zimbra *nixes?
    I know , I know that OSX is a tampered unix with nice GUI, but some stuff works different.
    2. Zimbra machine is on static IP, directly connected to internet. No NAT, no router. No firewall before Zimbra machine, but OSX built in firewall is ON - configured to open ports for Zimbra needed connections - LDAP, POP3, IMAP, SMTP, HTTP, HTTPS, IMAPS, POP3S, SSH and Zimbra administration (tcp7071).

  5. #5
    McBurtnieks is offline Member
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Default

    Quote Originally Posted by Mark Daniel View Post
    You may also want to modify your /etc/hostconfig file, and change "HOSTNAME" from "-AUTOMATIC-" to your FQDN (mail.mydomain.com).
    Thank you, Mark,
    My /etc/hostconfig file has no entry "HOSTNAME" at all...
    As I said, it's OS X, and stuff looks little bit different here.

    FYI, my /etc/hostconfig file content:

    Code:
    AFPSERVER=-NO-
    AUTHSERVER=-NO-
    AUTOMOUNT=-YES-
    CUPS=-AUTOMATIC-
    NFSLOCKS=-AUTOMATIC-
    NISDOMAIN=-NO-
    TIMESYNC=-YES-
    QTSSERVER=-NO-
    WEBSERVER=-NO-
    SMBSERVER=-NO-
    SNMPSERVER=-NO-
    SPOTLIGHT=-YES-
    ARDAGENT=-YES-
    One thing here is to switch spotlight off to improve performance, but thats offtopic here.
    May be the reason for Postfix hostname "stevezation" is that I changed HOSTS file with new entry about <webmail.mydomain.com> AFTER Zimbra was set up. And LDAP or other structure important to Zimbra internal management, picked up wrong name from default OSX...

  6. #6
    Mark Daniel's Avatar
    Mark Daniel is offline Senior Member
    Join Date
    May 2007
    Location
    Ferndale, MI
    Posts
    54
    Rep Power
    8

    Default leopard?

    (I'm a Mac-head, too, btw :) )

    Hrm! From the looks of your hostconfig, it looks like you're running Leopard (Mac OS X 10.5). Is this the case? Just FYI, ZCS isn't supported on that yet. Which is a major bummer.

    Regardless, you *should* be able to add that line, still, regardless of whether or not you're running client or Server.

    The ".local" tells me that postfix is using the hostname created by Bonjour. Setting that HOSTNAME variable in /etc/hostconfig should override that (I currently do that on my Mac OS X Server mail server, as well as my Zimbra server (which is also running on top of Mac OS X Server, but with all of the Apple-supplied services turned off).

  7. #7
    McBurtnieks is offline Member
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Default

    Quote Originally Posted by Mark Daniel View Post
    (I'm a Mac-head, too, btw )

    Hrm! From the looks of your hostconfig, it looks like you're running Leopard (Mac OS X 10.5). Is this the case?
    Salut to Brothers in Arms!
    As you can see in the begining of my first post, my "poor man's" server is running OSX Tiger v. 10.4.9 Client... So, that's the difference in Hostconfig, IMHO. Have no server, therefore I cannot verify that.

    Regardless, you *should* be able to add that line, still, regardless of whether or not you're running client or Server.

    The ".local" tells me that postfix is using the hostname created by Bonjour. Setting that HOSTNAME variable in /etc/hostconfig should override that...
    Yes, that's the question - is Zimbra's Postfix consulting OSX Hostname file at all, when sending out mail or not...

    I will look carefully in that, give a try... Lets see. It is not wise to experiment with "production" machine, but I see that Zimbra's site has very short info about setting up on Mac systems ... but here IS dragons, so I'll try to write sort of helper article someday. Neverthless, big thanks to Zimbra folks for this marvelous software, keep running good job

  8. #8
    davidh is offline Active Member
    Join Date
    Oct 2006
    Posts
    45
    Rep Power
    8

    Default

    There is another thread which details how you can tweak the postfix configuration to announce itself as another machine name here...

    Note. I have tried this successfully on Redhat, but not MacOS X. I see no reason that it wouldn't work however.

    Mail server host name in greeting

    Cheers,
    David

  9. #9
    McBurtnieks is offline Member
    Join Date
    Mar 2007
    Location
    Riga, Latvia
    Posts
    10
    Rep Power
    8

    Smile Thanks to all, problem solved!

    Finally changed my HELO greeting.
    I edited my main.cf file and added:
    Code:
    smtp_helo_name = mail.mydomain.com
    Note that this problem may be specific to Zimbra and Mac OS X Tiger - read first post in thread to get details, why it is specific. Average *nix user with correctly installed Zimbra server have correct Hostname already in place, so Zimbra's Postfix can grab it and use uncorected. If it is FQDN of course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  3. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •