Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: [SOLVED] having some problem in upgrading from the 4.5.7 to 4.5.9

  1. #1
    Max Ma is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    97
    Rep Power
    8

    Default [SOLVED] having some problem in upgrading from the 4.5.7 to 4.5.9

    Dear Sir,
    Having some trouble with two server that running zimbra 4.5.7 ?
    we try to update to 4.5.9 last night and both server failed.
    and then we try to recover from the full backup copy did it before the upgrade.
    one server running FC 5 X 86 version could not running, and even with the reinstallation the database is not working, user can not login.
    We have to use a copy of backup few days ago which was down on 4.5.6 and then upgrade to 4.5.7 which now working. But we have lost a few days email and account setting on it. And way we can restore those information on the backup to the current servers? they are now running in 4.5.7
    and also found some problem with the statistic report after upgrade to 4.5.7 on the FC5 machine. the report now working at all.
    many thanks,

    Max

  2. #2
    Costa-101's Avatar
    Costa-101 is offline Project Contributor
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    8

    Thumbs down

    I run a single server as my business.

    Take note to those who are joining Zimbra -- from someone who has backed them tooth and nail over the past year or two.

    Do not choose this option unless you are willing to put in more effort than a little ajax webmail is worth.

    After the acquisition of Zimbra by Yahoo - the first upgrade released has totally failed - I now stand in a position where i have to basically explain to my users that their emails are lost.

    Not because I don't have a backup but because it will be equivalent to finding millions of needles in a huge haystack.

    Meaning I now have to troll through the backed up 'zimbra' folder and somehow restore each message to the NEWLY installed 4.5.9 version.

    The update failed which basically botched my system -- all those ready to jump down my throat now, i have been updating since v4 release -- and i tried scouring every Zimbra blog and forum page (even translating some) to find solutions --- none.

    So i moved my old 'zimbra' folder to 'zimbra-backup' and installed a fresh copy -- failed.

    SO, i tried again.

    ..............

    I say thanks Yahoo, and I hope the Zimbra Originals are burning away your money dudes.

    I will be shortly moving away from Zimbra after this display - I am grateful for the last years stability.

    p.s. I may take my Wiki page with me in lui of services and clients lost
    ------------------------------
    http://www.lcrm.co.uk

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I'm sorry,
    Did you have a thread with your upgrade troubles? Any type of assertion that the upgrade had something to do with yahoo! is absolutely insane, and I suggest you research your information before posting.

    We provide support to you via via the forums, and the Zimbra Employees, moderators, and community members spend a lot of time helping out the community.

    I'm sorry you wish to hurt the community by "taking back" your wiki page. I didn't think they were owned by anyone, including us. They're owned by the community.

    If you still have your backup, perhaps we can try to restore it. Otherwise, Good luck with your new investment. I can promise you won't find anything close to the vibrancy of this community.

    Think about it for a second. Members in this forum have a direct line to Zimbra employees by virtue of using the product. A lot companies won't even talk to you unless you pay them.

    Let me know if I can help out.

    best wishes,
    john

  4. #4
    Costa-101's Avatar
    Costa-101 is offline Project Contributor
    Join Date
    Sep 2006
    Location
    Space station 101
    Posts
    182
    Rep Power
    8

    Thumbs up Sorry Zimbra - what amazing support.



    Anyone reading my previous post.

    An unbelievable thing happened about 2 minutes after I wrote my last host headed posting.

    The best Zimbra employee - you may have seen him JHolder sent me a private message and said 'if you let me ssh into your server I will sort it out for you'.

    Can you believe that - I was amazed as John and I chatted over iChat and basically he saved my skin.

    From a few hacked about folders John carefully and respectfully, worked his magic fixing permissions; renaming files and folders and copying files across.

    Occasionally John would pop up on the messenger and say 'have you got this file laying around' and 'have you got the install files at hand'. I only to willing supplied the necessary watching in ore as the master worked.

    Feeling, as he put so well, 'like I now have egg all over my face'.

    So time passed......

    I was watching and waiting....

    then John said if you run #tail -f /tmp/zmsetup.log.1964 you can watch the install process...can you believe it - I couldn't.

    Then he said 'OK see if you can login' al the users and all the emails are back.

    "Where do you want the donation made to John? - You're the man"

    "No donations, just promise me two things..

    1) Backup
    2) Ask us before you post a thread like the one below
    "

    Well, thanks John - I certainly will.

    Another funny thing he said was "If you get this support with the community edition - imagine what you get when you pay"

    So I did, and am looking forward to installing my Network Edition any day now.

    Thanks again John, I am so glad to still be here - a happy user and reseller of the great Zimbra application.
    ------------------------------
    http://www.lcrm.co.uk

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Glad to hear it!

    Alright Max, we're not forgetting about ya, though we need some more details on your troubles.

    Side note: If not already overwritten/if you try again (after another backup first!) could you throw an update log our way?

    Failed restore of backup: We're assuming you're on FOSS (you're on fedora afterall) and you backup is just a copy of /opt/zimbra

    So if I'm understanding you right, upgrade to .9 failed & you couldn't restore your .7 backup (the one before you tried .7 > .9)
    So you restored an even older .6 backup.
    What you need to do is get another isolated box up and get the .7 backup working. Pretty much just like you did in [SOLVED] About email lost

    See some of the notes Open Source Edition Backup Procedure - Zimbra :: Wiki & even here /blog/archives/2007/10/moving_zcs_to_another_server.html -you're not moving per say.

    The goal is to get that backup working on another machine so you can sort through accounts. Even if it's just forwarding lost mail to people in the web-client. Better would be copying stuff back with a thick-client. (If using thunderbird you need to append /tb on the end of the username so the dates don't mess up.) Better still would be if you could handle an imapsync.
    Last edited by mmorse; 10-30-2007 at 07:24 PM. Reason: clarity

  6. #6
    Max Ma is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    97
    Rep Power
    8

    Default About the 4.5.7 upgrade to 4.5.9

    Dear Jholder,

    I will try to restore to another machine due to this upgrade, I have to restore the machine to user to use.
    But I will try to restore to other spared machine and will post you the result today.

    BTW, I think Zimbra is great but just some time after the yahoo things, the support response become a bit slower then before.

    That is about it. Anyway, thanks for the reply.

  7. #7
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Cool-
    Let mike or me know if we can help.

    As far as support, we're having the usual growing pains. It has nothing to do with Yahoo, but I think that in people's minds, it marks a time frame. We're just growing quickly.

    We are hiring support people, if you know anyone

    Apply at hr@zimbra.com

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Quote Originally Posted by Max Ma View Post
    But I will try to restore to other spared machine and will post you the result today.
    Good, that's what I was looking to hear. I updated my post above to make it clearer, as I realized a translation would be horrible with my sentence fragments.

  9. #9
    Max Ma is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    97
    Rep Power
    8

    Default here is the installation log just did

    Dear Jholder,

    Further to you last reply, I have restore the backup into a newly installed machine on FC5 unit. which is the same as the producetion server.

    and
    could not pass the database verify section
    here is what on the screen:
    Operations logged to /tmp/install.log.2961
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-4.5.7_GA_1319
    zimbra-logger...FOUND zimbra-logger-4.5.7_GA_1319
    zimbra-mta...FOUND zimbra-mta-4.5.7_GA_1319
    zimbra-snmp...FOUND zimbra-snmp-4.5.7_GA_1319
    zimbra-store...FOUND zimbra-store-4.5.7_GA_1319
    zimbra-apache...FOUND zimbra-apache-4.5.7_GA_1319
    zimbra-spell...FOUND zimbra-spell-4.5.7_GA_1319
    zimbra-core...FOUND zimbra-core-4.5.7_GA_1319

    Saving existing configuration file to /opt/zimbra/.saveconfig
    cp: cannot stat `/opt/zimbra/java/jre/lib/security/cacerts': No such file or directory


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/collab...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p12-4.1
    libidn...FOUND libidn-0.6.2-1.1
    curl...FOUND curl-7.15.5-1
    fetchmail...FOUND fetchmail-6.3.6-2
    gmp...FOUND gmp-4.1.4-6.2.1
    bind-libs...FOUND bind-libs-9.3.2-4.1
    vixie-cron...FOUND vixie-cron-4.1-54
    /usr/lib/libstdc++.so.6...FOUND
    Checking current number of databases...

    Do you want to verify message store database integrity? [Y] Y
    Verifying integrity of message store databases. This may take a while.
    Can't open local config: No such file or directory at bin/zmdbintegrityreport line 109.

    And here is fromt he zimbra Log just now:
    Oct 31 01:50:02 mail zimbramon[2481]: 2481:info: 2007-10-31 01:50:02, DISK: : dev: /dev/mapper/VolGroup00-LogVol00, mp: /, tot: 149378, avail: 127240
    Oct 31 01:50:02 mail zimbramon[2481]: 2481:info: 2007-10-31 01:50:02, DISK: : dev: /dev/sda1, mp: /boot, tot: 99, avail: 84
    Oct 31 02:00:01 mail zimbramon[2666]: 2666:info: 2007-10-31 02:00:01, DISK: : dev: /dev/mapper/VolGroup00-LogVol00, mp: /, tot: 149378, avail: 127239
    Oct 31 02:00:01 mail zimbramon[2666]: 2666:info: 2007-10-31 02:00:01, DISK: : dev: /dev/sda1, mp: /boot, tot: 99, avail: 84
    Oct 31 02:10:01 mail zimbramon[2837]: 2837:info: 2007-10-31 02:10:01, DISK: : dev: /dev/mapper/VolGroup00-LogVol00, mp: /, tot: 149378, avail: 127239
    Oct 31 02:10:01 mail zimbramon[2837]: 2837:info: 2007-10-31 02:10:01, DISK: : dev: /dev/sda1, mp: /boot, tot: 99, avail: 84

    what can I do, please help?

  10. #10
    Max Ma is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    97
    Rep Power
    8

    Default This is the back up file just before the 4.5.9 problem

    Dear Jholder,

    this is the backup just before the 4.5.9 upgrade problem.
    Can you help to fix the and have it restore the database so we can have the message to retore or recovery to the user on the production server?

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 10-03-2007, 12:18 PM
  2. [SOLVED] Etch upgrade 4.5.6 to 4.5.7 problem.
    By jml75 in forum Installation
    Replies: 2
    Last Post: 09-28-2007, 05:20 PM
  3. Ldap Problem when upgrading from 4.5.1 to 4.5.2
    By skak in forum Administrators
    Replies: 0
    Last Post: 09-13-2007, 06:44 AM
  4. Problem Upgrading to 4.5.5 on Ubuntu 6.06 LTS
    By carlo in forum Installation
    Replies: 1
    Last Post: 05-14-2007, 11:11 AM
  5. Problem Upgrading from 4.0.1 to 4.0.x
    By shankwc in forum Installation
    Replies: 14
    Last Post: 11-19-2006, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •