Results 1 to 7 of 7

Thread: [SOLVED] Tomcat not running

  1. #1
    sicorpion is offline Awaiting Activation
    Join Date
    Jul 2007
    Location
    New Mexico
    Posts
    11
    Rep Power
    0

    Default [SOLVED] Tomcat not running

    Hello,

    I have reviewed several other " tomcat not running " issues on the forums, but I still can't get it back up. I took zimbra down for a back up and when I tried to re-start it, tomcat failed.

    Code:
    Oct 23 21:02:48 mail zmtomcatmgr[9241]: status requested
    Oct 23 21:02:48 mail zmtomcatmgr[9241]: stale pid 8249 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Oct 23 21:02:48 mail zmtomcatmgr[9241]: assuming no other instance is running
    Oct 23 21:02:48 mail zmtomcatmgr[9241]: no manager process is running
    Oct 23 21:02:48 mail zmtomcatmgr[9248]: start requested
    Oct 23 21:02:48 mail zmtomcatmgr[9248]: checking if another instance of manager is already running
    Oct 23 21:02:48 mail zmtomcatmgr[9248]: stale pid 8249 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Oct 23 21:02:48 mail zmtomcatmgr[9248]: assuming no other instance is running
    Oct 23 21:02:48 mail zmtomcatmgr[9249]: wrote manager pid 9249 to /opt/zimbra/log/zmtomcatmgr.pid
    Oct 23 21:02:48 mail zmtomcatmgr[9249]: manager started tomcat/JVM with pid 9250
    Oct 23 21:02:56 mail zmtomcatmgr[9249]: manager woke up from wait on tomcat/JVM with pid 9250
    Oct 23 21:02:56 mail zmtomcatmgr[9249]: manager started tomcat/JVM with pid 9265
    Oct 23 21:03:05 mail zmtomcatmgr[9249]: manager woke up from wait on tomcat/JVM with pid 9265
    Oct 23 21:03:05 mail zmtomcatmgr[9249]: tomcat/JVM exited twice in 9 seconds (tolerance=60)
    I have removed the stale PIDs and run /opt/zimbra/libexec/zmfixperm but still nothing. Also, the logger is down too and I think it been down for a few weeks, but didn't have tome to trouble shoot it

  2. #2
    sicorpion is offline Awaiting Activation
    Join Date
    Jul 2007
    Location
    New Mexico
    Posts
    11
    Rep Power
    0

    Default

    I also just upgraded to 4.5.9 and the problem persist. Additionally, I didn't realize this until just now, but I have the exact same problem on another server which I backed up moments before. So, I have two mail servers down with the same issues...no tomcat and no antivirus

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Please attach your /opt/zimbra/tomcat/log/catalina.out

    Rename it with a txt extension.

    john

  4. #4
    sicorpion is offline Awaiting Activation
    Join Date
    Jul 2007
    Location
    New Mexico
    Posts
    11
    Rep Power
    0

    Default

    John,

    Thanks for the help. change filetype to txt from pdf
    Attached Files Attached Files

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Looks like you've got another IMAP server or perdition running.
    Code:
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Address already in use
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
        at java.net.ServerSocket.bind(ServerSocket.java:319)
        at com.zimbra.cs.util.NetUtil.newBoundServerSocket(NetUtil.java:101)
        at com.zimbra.cs.util.NetUtil.bindServerSocket(NetUtil.java:124)
        at com.zimbra.cs.util.NetUtil.bindSslTcpServerSocket(NetUtil.java:57)
        at com.zimbra.cs.servlet.PrivilegedServlet.init(PrivilegedServlet.java:92)
        at javax.servlet.GenericServlet.init(GenericServlet.java:211)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1105)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:932)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3915)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4176)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:910)
        at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:873)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:474)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1118)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1020)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1012)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
        at org.apache.catalina.core.StandardService.start(StandardService.java:450)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:406)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.zimbra.cs.launcher.TomcatLauncher.start(TomcatLauncher.java:42)
        at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatLauncher.java:64)
    Try
    su - zimbra
    zmperditionctl stop
    tomcat start

    Then login and uncheck IMAP/POP3 Proxy

  6. #6
    sicorpion is offline Awaiting Activation
    Join Date
    Jul 2007
    Location
    New Mexico
    Posts
    11
    Rep Power
    0

    Default

    John,

    Thanks for your help again.... As it turns out, it was user error. I'm not sure how IMAPPROXY services got turned on, but they did.

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    -marking as [solved]

    For other's searching this thread later:
    If for some reason you can't get the box started to login to the admin console:
    zmprov -l modifyServer server.domain.com -zimbraServiceEnabled imapproxy
    zmcontrol stop/start
    (there's also -zimbraServiceInstalled)
    Note: You should not be running the perdition proxy on single server installs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tomcat, Java VM Problems - RAM related? Help
    By Mo_Hong in forum Administrators
    Replies: 3
    Last Post: 03-28-2007, 02:00 PM
  2. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •