Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: [SOLVED] Issues sending email externally

  1. #1
    drdre is online now Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    416
    Rep Power
    8

    Default [SOLVED] Issues sending email externally

    ok.. i setup my relay MTA... did as what i read to do and so forth..

    now i have setup a pop account xxx@chapmans.co.tt inside the accout i made in zimbra called andreb..

    now what i did was do a sample test send email to xxx@chapmans.co.tt and also to andre.b@gmail.com ..

    and so far the email hasnt reached yet.. and its been a while..

    also just to make sure my settings for the pop where working.. i logged into my gmail account andre.b@gmail.com and sent an email to andreb@chapmans.co.tt .. and i got it in a few seconds.. in my inbox in zimbra...

    is there any way for me to see if any errors happened or if i have my relay MTA informaion wrong ?

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by drdre View Post
    now what i did was do a sample test send email to xxx@chapmans.co.tt and also to andre.b@gmail.com ..
    I'm not really sure what you are describing here. Do you mean that you've gone to your preferences tab and created an external account named: andre.b@gmail.com - is that correct?

    Quote Originally Posted by drdre View Post
    and so far the email hasnt reached yet.. and its been a while..
    Did you hit the Get Mail button in Zimbra?

    Quote Originally Posted by drdre;60960also just to make sure my settings for the pop where working.. i logged into my gmail account [email
    andre.b@gmail.com[/email] and sent an email to andreb@chapmans.co.tt .. and i got it in a few seconds.. in my inbox in zimbra...
    Was the test email you sent earlier to andre.b@gmail.com in your gmail inbox?

    The "POP3 account" as you've called it is for retrieving mail from external accounts, is that what you're trying to do?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    drdre is online now Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    416
    Rep Power
    8

    Default

    interesting.. here is part of my zimbra.log file..

    <andreb@chapmans.co.tt>,<andre.bunting@gmail.com>, BODY=7BIT 250 2.6.0 Ok, id=26573-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as BB39F25702D9
    Sep 28 09:28:47 zimbra amavis[26573]: (26573-02) Passed CLEAN, LOCAL [10.0.0.6] [10.0.0.6] <andreb@chapmans.co.tt> -> <andreb@chapmans.co.tt>,<andre.bunting@gmail.com >, Message-ID: <2012412927.51190986122691.JavaMail.root@zimbra.ch apmans.co.tt>, mail_id: 1qiZJGc6Fwjj, Hits: -3.47, size: 581, queued_as: BB39F25702D9, 2722 ms
    Sep 28 09:28:47 zimbra postfix/smtp[16538]: CC2A025702D8: to=<andreb@chapmans.co.tt>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 Ok: queued as BB39F25702D9)
    Sep 28 09:28:47 zimbra postfix/smtp[16538]: CC2A025702D8: to=<andre.bunting@gmail.com>, relay=127.0.0.1[127.0.0.1], delay=4, status=sent (250 Ok: queued as BB39F25702D9)
    Sep 28 09:28:47 zimbra postfix/qmgr[16261]: CC2A025702D8: removed
    Sep 28 09:28:47 zimbra postfix/smtp[16542]: BB39F25702D9: to=<andreb@chapmans.co.tt>, relay=mail.mail.tt[66.162.166.26], delay=1, status=bounced (host mail.mail.tt[66.162.166.26] said: 550 not local host chapmans.co.tt, not a gateway (in reply to RCPT TO command))
    Sep 28 09:28:48 zimbra postfix/smtp[16542]: BB39F25702D9: to=<andre.bunting@gmail.com>, relay=mail.mail.tt[66.162.166.26], delay=2, status=bounced (host mail.mail.tt[66.162.166.26] said: 550 not local host gmail.com, not a gateway (in reply to RCPT TO command))
    Sep 28 09:28:48 zimbra postfix/cleanup[16537]: 2DC7925702DA: message-id=<20070928132848.2DC7925702DA@zimbra.chapmans.co .tt>
    Sep 28 09:28:48 zimbra postfix/qmgr[16261]: 2DC7925702DA: from=<>, size=3501, nrcpt=1 (queue active)
    Sep 28 09:28:48 zimbra postfix/qmgr[16261]: BB39F25702D9: removed
    Sep 28 09:28:49 zimbra postfix/smtp[16542]: 2DC7925702DA: to=<andreb@chapmans.co.tt>, relay=mail.mail.tt[66.162.166.26], delay=1, status=bounced (host mail.mail.tt[66.162.166.26] said: 550 not local host chapmans.co.tt, not a gateway (in reply to RCPT TO command))

    look at the part where is states "status=bounced" could it be that my relay_MTA information is configured wrong ?

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by drdre View Post
    look at the part where is states "status=bounced" could it be that my relay_MTA information is configured wrong ?
    Yes, that's more than likely the problem. As I mentioned above, I'm not really sure what, from your description, you are trying to achieve nor what you've changed in Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    drdre is online now Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    416
    Rep Power
    8

    Default

    ok guys.. this is what i have done.... i have done a clean install of my centos5 ..

    did all the updates it needs..

    now this is what i want zimbra to be able to do for me.

    1) I have the internet domain chapmans.co.tt, at which we get all of our new emails would be coming from. (eg info@chapmans.co.tt). I want my internal email server(zimbra) to be able to download the email from it and allow me to send emails external too.

    2)If an email is for from andreb@chapmans.co.tt to markc@chapmans.co.tt in zimbra, i dont want the email to go to the external mail server and then come back in.

    ok.. now that i have stated what i need it to do.. hopefully i will be guided to avoid the mistakes i have made before.. which i believe is just me configuring BIND wrong.

    So i got a clean install and i need your HELP!

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    So is this a pop download or are you forwarding from the external mail server? It would appear to be pop from :
    Quote Originally Posted by drdre View Post
    1) I have the internet domain chapmans.co.tt, at which we get all of our new emails would be coming from. (eg info@chapmans.co.tt). I want my internal email server(zimbra) to be able to download the email from it and allow me to send emails external too.
    Quote Originally Posted by drde
    now i have setup a pop account xxx@chapmans.co.tt inside the accout i made in zimbra called andreb..
    pop: to get it to auto download - webmin/fetchmail or use v5 which now has Bug 14527 - Periodic POP and IMAP aggregation and frequency and limit controls for same

    Quote Originally Posted by drdre View Post
    2)If an email is for from andreb@chapmans.co.tt to markc@chapmans.co.tt in zimbra, i dont want the email to go to the external mail server and then come back in.
    it's going to keep the traffic withing zimbra, it's "relay for external delivery"

    PM:
    Quote Originally Posted by drdre
    Re: An i get a moment of your time ?
    Just for some advice on how best to configure bind ?
    I use another dns solution myself -so I may not be able to get too technical as to your problem- but could you post your BIND config -/etc/named.conf for others to look at?

    Quickly glancing through your prior threads I see you've seen Split DNS - ZimbraWiki
    but I don't know if you've seen /blog/archives/2007/06/making_zimbra_bind_work_together_1.html
    Last edited by mmorse; 10-05-2007 at 08:52 AM.

  8. #8
    drdre is online now Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    416
    Rep Power
    8

    Default

    Interesting... thanks for the help on the split DNS.. it helped... but now i get a new problem

    "This is the Postfix program at host zimbra.chapmans.co.tt.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <andre.bunting@gmail.com>: host mail.mail.tt[66.162.166.26] said: 550 not local
    host gmail.com, not a gateway (in reply to RCPT TO command)

    <storage@wow.net>: host mail.mail.tt[66.162.166.26] said: 550 not local host
    wow.net, not a gateway (in reply to RCPT TO command) "

    isnt 550 error a password error ? or if i am wrong.. ..

    i have done whats suggested here : Outgoing SMTP Authentication - ZimbraWiki .. and i have ensured that i use the correct username and password.. .

    so right now i totally confused..

    I can send email internal.. but not externally .. now i am almost there... and Zimbra is GREAT !!!
    Last edited by drdre; 10-03-2007 at 03:33 PM.

  9. #9
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    The 550 fatal is probably:
    a) because it won't relay
    Do you have to specifically allow relaying from your zimbra.chapmans.co.tt IP on this mail.mail.tt box?
    b) it can relay but isn't accepting your authentication

    -search the web for "550 not local host not a gateway"
    Last edited by mmorse; 10-05-2007 at 08:23 AM.

  10. #10
    drdre is online now Elite Member
    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    416
    Rep Power
    8

    Default

    ahh.. i am so lost now

    here is my postfix main.cf

    i hope someone can help me !!!

    ender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
    virtual_alias_domains = ldap:/opt/zimbra/conf/ldap-vad.cf
    recipient_delimiter =
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_auth_only = no
    myhostname = zimbra.chapmans.co.tt
    virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
    mydestination = localhost
    mailbox_size_limit = 0
    smtpd_client_restrictions = reject_unauth_pipelining
    virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
    transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
    sendmail_path = /opt/zimbra/postfix-2.2.9/sbin/sendmail
    message_size_limit = 10240000
    broken_sasl_auth_clients = yes
    alias_maps = hash:/etc/aliases
    manpage_directory = /opt/zimbra/postfix-2.2.9/man
    smtpd_helo_required = yes
    daemon_directory = /opt/zimbra/postfix-2.2.9/libexec
    virtual_transport = error
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit
    smtpd_tls_loglevel = 1
    relayhost = mail.mail.tt
    disable_dns_lookups = yes
    content_filter = smtp-amavis:[127.0.0.1]:10024
    virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
    version = 2.2.9
    mailq_path = /opt/zimbra/postfix-2.2.9/sbin/mailq
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    smtpd_use_tls = yes
    queue_directory = /opt/zimbra/postfix-2.2.9/spool
    newaliases_path = /opt/zimbra/postfix-2.2.9/sbin/newaliases
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_reject_unlisted_recipient = no
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    command_directory = /opt/zimbra/postfix-2.2.9/sbin
    smtpd_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/opt/zimbra/conf/relay_password
    smtp_sasl_auth_enable = yes
    smtp_sasl_security_options = noanonymous

    hrm.. hopefully this will give you guysn more insight to how i have things setup.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 11-07-2010, 01:54 PM
  2. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •