Results 1 to 10 of 10

Thread: >10k emails in active queue... :(

  1. #1
    Predatorz is offline Intermediate Member
    Join Date
    Jun 2007
    Posts
    19
    Rep Power
    8

    Default >10k emails in active queue... :(

    Hi, I am using zimbra OSS v4.5.5.

    Over the weekend, our mail server received >10k Emails, got choked in the active queue thus causing problems in receiving/sending email. we have since rebooted the server and after fixing the clamd not able to start up proble, the mail server is back online.
    We have moved the >10k email to the Hold Queue.

    How do we increase the active queue size to accomodate >10k of emails?
    And is there any good way for us to purge all the emails to all the mail recipients while allowing the mail server to continue to send & receive emails?


    Thanks for any help/suggestions rendered.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by Predatorz View Post
    Hi, I am using zimbra OSS v4.5.5.

    Over the weekend, our mail server received >10k Emails, got choked in the active queue thus causing problems in receiving/sending email. we have since rebooted the server and after fixing the clamd not able to start up proble, the mail server is back online.
    We have moved the >10k email to the Hold Queue.

    How do we increase the active queue size to accomodate >10k of emails?
    And is there any good way for us to purge all the emails to all the mail recipients while allowing the mail server to continue to send & receive emails?


    Thanks for any help/suggestions rendered.
    Hi Predatorz,
    Welcome to the forums, and I'm sorry that you're having trouble.
    Zimbra should have been able to handle this. If you've fixed the clam av, problem, then I would suggest requeing the e-mail messages and then running postqueue -f.

    You can also turn off clamav for the time being, and deliver the messages. We should be releasing 4.5.7 which fixes this issue, very soon.

    Sincerely,
    john

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I'm supprised their in the active queue, the clamav problem usually has them in the deferred. Once you fix your problem, they won't (unless forced) all try again at the exact same time. The active queue size is limited on purpose, because it deals with current memory.

    You said that their now in the hold-just release them-and if need be do it in groups. Just re-queuing as apposed to then flushing after you release, may reduce the strain a bit. (If this was v5beta-with posfix 2.4, you could also do postqueue -i queue_id, to just deal with the hold queue and not affect any mail in the other queues, but you did say v4.5.5 which has an older version of postfix.)

    Though postsuper -r ALL hold (hold can = any queue_id) should work. However, I always avoid 'postsuper' because -r reque is easily confused with -d delete; you could accidentally think it was 'remove' and 'delay' instead. And -h and -H have totally different purposes -one holds the other releases. And -H ALL hold acts different than -r (-H keeps the max lifetime running!) The confusion happens more than you think, which is why I pull up a man page first when using postsuper.

    John is also exactly right when he says "Zimbra should have been able to handle this. If you've fixed the clam av, problem, then I would suggest requeing the e-mail messages and then running postqueue -f."

    Deferred can scale quite bigger...If you still want to increase active - ram issues asside:
    qmgr_message_active_limit which is the max number of messages the active queue can hold.
    So it would be like: postconf -e 'qmgr_message_active_limit = 20000'

    While your at it, be aware that the sum total of the recipeients in the active queue won't exceed qmgr_message_recipient_limit/default_recipient_limit

    (Because I know you'll come across it...smtpd_recipient_limit refers to the max number of recipients per email, and it applies to all queues. And if you mess with that be advised of your smtpd_recipient_overshoot_limit)
    Last edited by mmorse; 09-17-2007 at 09:35 AM.

  4. #4
    Predatorz is offline Intermediate Member
    Join Date
    Jun 2007
    Posts
    19
    Rep Power
    8

    Default

    Am i right to say that postqueue -f will flush all emails in all queues(Deferred, Incoming, Active, Hold & Corrupt?)

    Thanks again!
    Last edited by Predatorz; 09-17-2007 at 11:07 AM.

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Postqueue should flush everything. If things still hang around, please post your /var/log/zimbra.log

  6. #6
    plumsicle is offline Member
    Join Date
    Jan 2008
    Posts
    11
    Rep Power
    7

    Default

    Hello,

    I don't get 10k emails in the active queue but I can have anywhere between 1k and 2k. The problem is, is that the emails are being delivered very slowly as the antispam-virus is scanning all the emails and takes a very long time. Many spam emails are being sent to users that don't even exist in my domain yet the amavsid is still scanning them and it's bogging everything down. I've looked on various threads and I have tried to resolve the issues but to no avail. I'm running the NE version 5.0 and I've had trouble finding information on this Clam AV problem to see if I have it. We've been running through zimbra for about a year now and it only started to occur around November during the time we were running 4.5.7 and upgrading did not help as much as I had hoped.

    Thanks in advance,
    Jason.

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    You may wish to change the entry in /opt/zimbra/conf/zmmta.cf for smtpd_reject_unlisted_recipient from 'no' to 'yes', save the file, then as the zimbra user run 'postfix reload'.

  8. #8
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    What is the load on the server like? Something like that sounds more to be a capacity issue. Number of users/hardware spec?

  9. #9
    plumsicle is offline Member
    Join Date
    Jan 2008
    Posts
    11
    Rep Power
    7

    Default

    I've already changed that setting in zmmta.cf as per another thread. The issues still continued where emails go up to about 1000 and takes about an hour for me to send an email within the domain and even to myself.

    Running a quad-core 2.8 Xeon processor with 4GB of RAM.

    We have approximately 120 users.

    Thanks,
    Jason.

  10. #10
    plumsicle is offline Member
    Join Date
    Jan 2008
    Posts
    11
    Rep Power
    7

    Default

    Another thing, would Postini have any impact on this situation? We are running that as our spam filter before hitting the zimbra server.

    Thanks again,
    Jason.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Errors because of Deffered emails
    By mansuper in forum Administrators
    Replies: 0
    Last Post: 11-20-2006, 04:08 PM
  2. Deleting emails before a particular date
    By mansuper in forum Zimbra in Education
    Replies: 6
    Last Post: 11-16-2006, 02:57 PM
  3. Missing emails
    By dusty_nz in forum Administrators
    Replies: 1
    Last Post: 10-24-2006, 10:34 PM
  4. Not receiving emails
    By koby in forum Installation
    Replies: 2
    Last Post: 08-28-2006, 03:29 AM
  5. emails don't show up in inbox in browser
    By pstelzer in forum Installation
    Replies: 10
    Last Post: 12-13-2005, 10:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •