Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Relaying Disaster...please HELP!

  1. #1
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default [SOLVED] Relaying Disaster...please HELP!

    I tried to run
    ./zmprov to allow relayin from another IP set...

    now all incoming mail is held in defered.
    How do I figure out wha the issue is>?

    I restored relaying to the original ip set only with

    ./zmprov modifyServer cpe.cortpump.com zimbraMtaMyNetworks '127.0.0.0/8 208.243.90.0/24'

    Please Help

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    try to flush the queue
    postconf -f

    Also, did you follow these instructions?
    Outgoing Mail Problems - ZimbraWiki

  3. #3
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default

    I reviewed the link at it seems that I've done the correct thing....

    ./postconf -f


    returns


    /opt/zimbra/postfix-2.2.9/sbin/postconf: invalid option -- f
    /opt/zimbra/postfix-2.2.9/sbin/postconf: fatal: usage: /opt/zimbra/postfix-2.2.9/sbin/postconf [-c config_dir] [-d (defaults)] [-e (edit)] [-h (no names)] [-l (lock types)] [-m (map types)] [-n (non-defaults)] [-v] [name...]


    Any other ideas?


    heres the error I get when I hover the deferred messages...



  4. #4
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default Looks like

    It looks like theres something to do with the clamav scanner?

  5. #5
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default

    root@cpe:/opt/zimbra/postfix-2.2.9/sbin# ./postconf mynetworks


    returns this


    mynetworks = 127.0.0.0/8 208.243.90.0/24

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Yeah, looks like you an is down. We've seen this and its a pretty big bug in clamav.

    To fix, you can
    su - zimbra
    mkdir /tmp/clamdb
    mv /opt/zimbra/clamav/db/* /tmp/clamdb
    zmprov ms `zmhostname` +zimbraServiceEnabled antivirus
    /opt/zimbra/clamav/bin/freshclam --config-file=/opt/zimbra/conf/freshclam.conf
    zmamavisctl stop
    zmamavisctl start

  7. #7
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default

    Got through the backup and when command below was issued I got an error...




    zimbra@cpe:~/bin$ /opt/zimbra/clamav/bin/freshclam --config-file=/opt/zimbra/conf/freshclam.conf

    ERROR: Problem with internal logger (UpdateLogFile = /opt/zimbra/log/freshclam.log).

    reading that freshclam.log now....

  8. #8
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default

    ily.cvd updated (version: 4107, sigs: 16433, f-level: 21, builder: ccordes)
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Current functionality level = 15, recommended = 21
    DON'T PANIC! Read Clam AntiVirus
    Database updated (149596 signatures) from db.us.clamav.net (IP: 129.64.99.170)
    WARNING: Clamd was NOT notified: Can't connect to clamd on 127.0.0.1:3310


    Looks like I still have an issue...can I go on without clamav?

  9. #9
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I'd stop zimbra altogether, and wipe the clamav dir /opt/zimbra/clamav.xxx (newest ver)
    then rerun the installer with the -s option.
    ./install.sh -s

    You can also turn off clam in the admin console, but you will be vulnerable to viruses.

  10. #10
    timothyalangorman is offline Special Member
    Join Date
    May 2007
    Posts
    173
    Rep Power
    7

    Default

    This post below Resolved the issue....

    [SOLVED] Clamav problem ? What's happening ?


    +++++++++++++++++++++++++++++++++++++++++++++
    Originally Posted by aNt1X View Post
    Ok, i solved modifying the watchdog interval in /opt/zimbra/libexec/zmmtaconfig

    [code]
    my %config = (
    progname => "zmmtaconfig",
    hostname => $ENV{zimbra_server_hostname},
    loglevel => 3,
    watchdog => 1,
    wd_all => 0,
    debug => 0,
    interval => 180,
    baseDir => "/opt/zimbra",
    logStatus => ( 4 => "Debug", 3 => "Info", 2 => "Warning", 1 => "Error", 0 =$
    );[code]

    (i extended the interval value from 60 to 180).

    I was going crazy looking at crontabs, but this watchdog process wasn't in the crontab, but in this perl script

    I hope it will not break something else ...

    Thank you anyway.

    aNt1X
    ++++++++++++++++++++++++++++++++++++++++

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about redo logs and disaster recovery
    By dlochart in forum Administrators
    Replies: 10
    Last Post: 08-12-2008, 03:40 AM
  2. remote location relaying denied...
    By timothyalangorman in forum Migration
    Replies: 0
    Last Post: 08-29-2007, 09:15 AM
  3. Disaster Recovery on a Multi Server Configuration
    By dlochart in forum Administrators
    Replies: 2
    Last Post: 04-14-2007, 05:08 AM
  4. Disaster Recovery Steps for v3.1.4 Network Edition
    By ThorGoLucky in forum Administrators
    Replies: 0
    Last Post: 09-08-2006, 11:08 AM
  5. Recovering from disaster when suddenly...nothing happens
    By ThorGoLucky in forum Administrators
    Replies: 1
    Last Post: 09-01-2006, 05:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •