Results 1 to 8 of 8

Thread: [SOLVED] No logrotate for zmmtaconfig.log?

  1. #1
    fisch09 is offline Special Member
    Join Date
    Dec 2006
    Location
    Melbourne, VIC, Australia
    Posts
    120
    Rep Power
    8

    Default [SOLVED] No logrotate for zmmtaconfig.log?

    Hi,

    My /opt/zimbra/log/zmmtaconfig.log is about 1.5GB (after one week) and all other logs are nicely rotated but zmmtaconfig.log isn't.

    Does anyone else has the same problem?

    ZCS 4.5.6 NE on Ubuntu 6.06

    Kind Regards
    Andre

  2. #2
    jpcaldwell is offline Active Member
    Join Date
    Sep 2006
    Location
    Seattle, WA
    Posts
    45
    Rep Power
    8

    Default

    Yeah, I see the same thing. 4.5.6 OSS on Centos 4.4, my zmmtaconfig.log is 2.1GB

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    If any of you have the chance to...when you zmcontrol stop/start does it empty?

  4. #4
    jpcaldwell is offline Active Member
    Join Date
    Sep 2006
    Location
    Seattle, WA
    Posts
    45
    Rep Power
    8

    Default

    nope, doesn't empty for me.

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    guess you could temporarily edit /opt/zimbra/libexec/zmmtaconfig and change the default loglevel (on line 55ish) to something lower -change it from 5 to 3

    This will be in 4.5.7:
    Bug 18445 - zmmtaconfig default loglevel is set to high
    Could one of you make a bugzilla entry for 'logrotate zmmtaconfig.log'? Of course let us know the number-thanks!
    Last edited by mmorse; 08-08-2007 at 07:34 PM. Reason: logrotate zmmtaconfig.log

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by jpcaldwell View Post
    nope, doesn't empty for me.
    Delete it (move it to another name if you really care to keep it) edit the loglevel, and reboot, it should create a new log with entries that are still every 120sec or so, but a lot less verbose if the level is set to 3.

  7. #7
    fisch09 is offline Special Member
    Join Date
    Dec 2006
    Location
    Melbourne, VIC, Australia
    Posts
    120
    Rep Power
    8

    Default

    ok - this is maybe a temp solution, but why is is not included in logrotate?

    Cheers
    Andre

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  2. logrotate breaks logger functionality
    By grmbl in forum Administrators
    Replies: 3
    Last Post: 04-26-2006, 10:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •