Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Zimbra died

  1. #1
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Exclamation Zimbra died

    Hello,

    just a few minutes ago, all zimbra services died (exactly just a zmcontrol stop does). I verified trough netstat on open ports and zmcontrol, with zero results. I'm the only user with access to this machine, and there is no suspect activity in the logs (about other people).

    What can be happened, and where do I search for discover this critical problem? The only things I found was:

    from /var/log/maillog and /var/log/zimbra.log (the same entries):
    Code:
    Jul 17 09:18:57 mail zmtomcatmgr[7548]: threaddump requested
    Jul 17 09:18:57 mail zmtomcatmgr[8352]: sending SIQUIT to tomcat/JVM process 8353
    Jul 17 09:18:59 mail zmtomcatmgr[7555]: stop requested
    Jul 17 09:18:59 mail zmtomcatmgr[7555]: waiting for manager process 8352 to die
    Jul 17 09:18:59 mail zmtomcatmgr[8352]: shutdown requested, sending TERM signal to 8353
    Jul 17 09:19:01 mail zmtomcatmgr[8352]: tomcat/JVM process exited (waitpid expected 8353 got 8353)
    Jul 17 09:19:01 mail zmtomcatmgr[8352]: manager woke up from wait on tomcat/JVM with pid 8353
    Jul 17 09:19:02 mail zmtomcatmgr[7555]: manager process 8352 died, shutdown completed
    Jul 17 09:19:02 mail postfix/postfix-script: stopping the Postfix mail system
    Jul 17 09:19:02 mail postfix/master[6694]: terminating on signal 15
    Jul 17 09:19:02 mail zmtomcatmgr[7649]: threaddump requested
    Jul 17 09:19:02 mail zmtomcatmgr[7649]: file /opt/zimbra/log/zmtomcatmgr.pid does not exist
    Jul 17 09:19:02 mail zmtomcatmgr[7649]: assuming no other instance is running
    Jul 17 09:19:02 mail zmtomcatmgr[7649]: no manager process is running
    Jul 17 09:19:04 mail zmtomcatmgr[7656]: stop requested
    Jul 17 09:19:04 mail zmtomcatmgr[7656]: file /opt/zimbra/log/zmtomcatmgr.pid does not exist
    Jul 17 09:19:04 mail zmtomcatmgr[7656]: assuming no other instance is running
    Jul 17 09:19:04 mail zmtomcatmgr[7656]: no manager process is running
    from /var/log/secure:
    Code:
    Jul 17 09:18:57 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/libexec/zmtomcatmgr threaddump
    Jul 17 09:18:59 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/libexec/zmtomcatmgr stop
    Jul 17 09:19:02 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/postfix-2.2.9/sbin/postalias /etc/aliases
    Jul 17 09:19:02 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/postfix-2.2.9/sbin/postfix stop norewrite
    Jul 17 09:19:02 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/libexec/zmtomcatmgr threaddump
    Jul 17 09:19:04 mail sudo:   zimbra : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/opt/zimbra/libexec/zmtomcatmgr stop
    hugo ribeiro

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    what does dmesg and /var/log/messages show ?

  3. #3
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    /var/log/messages:
    Code:
    Jul 17 09:18:55 mail saslauthd[6733]: server_exit     : master exited: 6733
    Jul 17 09:18:55 mail amavis[6636]: Net::Server: 2007/07/17-09:18:55 Server closing!
    dmesg nothing.
    hugo ribeiro

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    what does uptime show ? looks like the server has rebooted itself.

  5. #5
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    The server did not restart. Even because, if it had restarted, zimbra services would have been started again.

    Code:
    [root@mail log]# uptime
     10:21:04 up 23 days, 23:35,  2 users,  load average: 0.03, 0.03, 0.04
    Thanks for your quick reply
    hugo ribeiro

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Just check to see how big your catalina.log file is :-

    Bug 13831 - tomcat crashes when catalina.out reaches 2GB

  7. #7
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    Unlucky today

    Code:
    [root@mail logs]# ls -lhd catalina.out
    -rw-rw-rw- 1 zimbra zimbra 97K Jul 17 09:34 catalina.out
    hugo ribeiro

  8. #8
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Have you checked in catalina.out to see if there any error messages? Also grep through your /var/log/messages.* for anything memory or kernel related. Is it a old server ? May be worth running a memtest on it.

    Sorry if it sounds like i am clutching at straws a bit

  9. #9
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    I don't know what exactly search on catalina.out file, not familiar with this java output

    I've already search /var/log/messages* and there is nothing related to any "non-zimbra-piece" problem.

    The server is a "fresh and young" IBM x3550 with 1x Xeon Quad-core, 4gb RAM, 2x300gb sas 10k, running centos 5...I believe there is no problems with it. Actually, there is only 3 users using the server, I'm "migration" process, hoping kill actual mail server in 1 month.

    Thank you for your effort on resolve this, anyway
    And sorry for my bad english hehe

    Anyone from zimbra have any idea on this?
    hugo ribeiro

  10. #10
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    You say three users are using the machine, do they have command line access aswell ? Do they have Administrator access to the Zimbra console? If so are you sure that one of them has not accidentally closed down Zimbra

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  2. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  3. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •