Results 1 to 2 of 2

Thread: Cluster incorrectly upgraded with non-cluster install.sh

  1. #1
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    718
    Rep Power
    9

    Default Cluster incorrectly upgraded with non-cluster install.sh

    ...how can I recover?

    One node of a single-server one+one RedHat cluster (RHEL4U6 64-bit) was upgraded from 4.5.5NE to 4.5.6NE using zcs/install.sh, without following the documented cluster upgrade procedure. Among the problems this caused was slapd not starting and the conf symlink to mountpoints being moved out of the way and recreated as a directory.

    We are currently running with just one node, and getting errors in the admin GUI (presumably because of failure to communicate with the second node). How can we upgrade or recreate the second node?

    FWIW, error when trying to browse Server Status at server:7071 is:
    Code:
    Message: system failure: java.lang.StringIndexOutOfBoundsException: String index out of range: -11
    Error code: service.FAILURE
    Method: ZmCsfeCommand.invoke
    Details:soap:Receiver
    Btw, install.sh should be modified to detect clustering and abort, thereby preventing this user error.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi Rich,
    I've been following your support ticket, hence I didn't reply.

    As far as the installer, see bug:
    Bug 18426 - installer should detect cluster install

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installation on FC3 under Xen
    By andreground in forum Installation
    Replies: 9
    Last Post: 11-14-2005, 10:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •